openSUSE安装天体软件Stellarium
openSUSE    2016-08-02 22:00:11    236    0    0
tianwaifeixian   openSUSE


这个软件官方源里面有 我一开始不知道 呃呃呃~
  924  tar xvf stellarium-0.15.0.tar.gz    925  ls   926  cd stellarium-0.15.0/   927  ls   928  tere   929  tree   930  ls -l   931  cat README  ----------------------------------------------------------------------------------------  1002  cd stellarium-0.15.0/  1003  ls  1004  mkdir -p builds/unix  1005  ls  1006  cd builds//unix/  1007  ls  967  sudo zypper in SDL   972  sudo zypper in libSDL_mixer-1_2-0 libSDL_mixer-devel  984  sudo zypper in doxygen  998  sudo zypper in libqt4-devel  1011 sudo zypper install cmake  1012  cmake ../..  1013  sudo zypper install cmake  1016  sudo zypper in libQt5Core-devel   1019  sduo zypper in libQt5Concurrent-devel   1020  sudo zypper in libQt5Concurrent-devel   1023  sudo zypper in libQt5Gui-devel   1026  sudo zypper in V  1027  sudo zypper in libQt5Network-devel  1030  sudo zypper in libQt5OpenGL-devel  1033  sudo zypper in Qt5PrintSupport-devel  1034  sudo zypper in libQt5PrintSupport-devel  1037  sudo zypper in libQt5SerialPort5-32bit  1041  sudo zypper in libqt5-qtserialport-devel  1045  sudo zypper in libqt5-qtscript-devel  1049  sudo zypper in -y libqt5-qtmultimedia-devel  1052  sudo zypper in -y libQt5Test-devel  1057  sudo zypper in -y libqt5-linguist-devel liangzi@suse:~/stellarium-0.15.0/builds/unix> cmake ../.. -- Found Qt5: /usr/lib64/qt5/bin/qmake (found suitable version "5.5.1") -- Configuring done -- Generating done -- Build files have been written to: /home/liangzi/stellarium-0.15.0/builds/unix liangzi@suse:~/stellarium-0.15.0/builds/unix> cmake -DCMAKE_INSTALL_PREFIX=/opt/stellarium ../.. -- Found Qt5: /usr/lib64/qt5/bin/qmake (found suitable version "5.5.1") -- Configuring done -- Generating done -- Build files have been written to: /home/liangzi/stellarium-0.15.0/builds/unix


以上是安装部分记录

官方wiki有详细说明

Compilation_on_Linux

网盘rpm包地址 https://yunpan.cn/c6qpAAKfaCQtJ (提取码:453b)


本人机器是64位 系统自带Qt所以官方那个Qt的安装部分省略了 不过相关依赖还得装 要不然过不去

装完之后KDE菜单启动项无法启动 报错  KDEINIT 无法启动“KSYSTRAYCMD

解决办法就是去掉那个 放在系统托盘中的选项 连接在这里:

右键 程序启动器(图标)====>编辑应用程序…====>选择对应的应用,比如我这里是thunderbird ===>去掉 放在系统托盘中 选项。也就是如下配置:

KDEINIT 无法启动“KSYSTRAYCMD”错误解决


上一篇: ubuntu on windows10

下一篇: openSUSE安装永中office

236 人读过
立即登录, 发表评论.
没有帐号? 立即注册
0 条评论
文档导航