XX-NET for openSUSE
openSUSE    2016-12-01 23:23:35    285    0    0
tianwaifeixian   openSUSE

这个发行版和目前网上流行的配置还不一样

github项目:https://github.com/XX-net/XX-Net 里面只有ubuntu发行版的配置方法

和我这个发行版配置不一样

检查当前代理配置:这里不会输出内容 说明之前没配置过(或者没成功配置过代理)

echo $http_proxy
 

openSUSE配置代理在yast里面

直接找网络服务 代理

把:http://127.0.0.1:8086/proxy.pac:8087 写到里面 选择对所有协议使用同一代理搞定 

以前我写的配置文件不对 

还以为是防火墙的原因呢

配置完之后注销从新登录

echo $http_proxy
http://127.0.0.1:8086/proxy.pac:8087​

贴一下配置文件:

~> less /etc/sysconfig/proxy > proxy.txt 
~> cat -n proxy.txt  
     1  ## Path:        Network/Proxy 
     2  ## Description: 
     3  ## Type:        yesno                                                                                              
     4  ## Default:     no                                                                                                 
     5  ## Config:      kde,profiles 
     6  # 
     7  # Enable a generation of the proxy settings to the profile. 
     8  # This setting allows to turn the proxy on and off while 
     9  # preserving the particular proxy setup. 
    10  #  
    11  PROXY_ENABLED="yes" 
    12 
    13  ## Type:        string 
    14  ## Default:     "" 
    15  # 
    16  # Some programs (e.g. lynx, arena and wget) support proxies, if set in 
    17  # the environment.  
    18  # Example: HTTP_PROXY="http://proxy.provider.de:3128/" 
    19  HTTP_PROXY="http://127.0.0.1:8086/proxy.pac:8087" 
    20 
    21  ## Type:        string 
    22  ## Default:     "" 
    23  # 
    24  # Some programs (e.g. lynx, arena and wget) support proxies, if set in 
    25  # the environment.  
    26  # This setting is for https connections 
    27  HTTPS_PROXY="http://127.0.0.1:8086/proxy.pac:8087" 
    28 
    29  ## Type:        string 
    30  ## Default:     "" 
    31  # 
    32  # Example: FTP_PROXY="http://proxy.provider.de:3128/" 
    33  # 
    34  FTP_PROXY="http://127.0.0.1:8086/proxy.pac:8087" 
    35 
    36  ## Type:        string 
    37  ## Default:     "" 
    38  # 
    39  # Example: GOPHER_PROXY="http://proxy.provider.de:3128/" 
    40  # 
    41  GOPHER_PROXY="" 
    42 
    43  ## Type:        string(localhost) 
    44  ## Default:     localhost 
    45  # 
    46  # Example: NO_PROXY="www.me.de, do.main, localhost" 
    47  # 
    48  NO_PROXY="127.0.0.1" 
    49 
    50  ## Type:        string 
    51  ## Default:     "" 
    52  # 
    53  # Example: SOCKS_PROXY="socks://proxy.example.com:8080" 
    54  # 
    55  SOCKS_PROXY="http://127.0.0.1:8086/proxy.pac:8087" 
    56 
    57  ## Type:        string 
    58  ## Default:     "" 
    59  # 
    60  # Example: SOCKS5_SERVER="office-proxy.example.com:8881" 
    61  # 
    62  SOCKS5_SERVER="http://127.0.0.1:8086/proxy.pac:8087"​

设置完之后更新中科大的源会有无法更新的提示

解决方法:

更换为阿里云开源镜像的源

关闭代理依然可以上google我操~

上一篇: vimrc-update/Vim+Cscope+Ctags+....

下一篇: Ckermit

285 人读过
立即登录, 发表评论.
没有帐号? 立即注册
0 条评论
文档导航