Qt5.7---qmlscene未安装 QtCreator无法输入中文
openSUSE    2017-01-22 19:43:12    423    0    0
tianwaifeixian   openSUSE

42.1系统自带有Qt版本是5.5的

官方网站Install_Qt_5_on_openSUSE装了个5.7的 看着果然进步不少 哈哈~

需要申请一下 免费的

gitbooks

==============================

解决qmlscene未安装:

系统自带的版本和我后来有从源里面安装的Qt4一共两个版本 

然后又从官网下载的5.7

刚才设置版本(工具-选项-Qt-version)添加5版本的提示 qmlscene未安装

看了一下自己添加的5版本目录是系统目录 

然后

# find -name "qmlscene"
./var/run/media/xuan/60169D27169CFEEA/Users/liangzi/AppData/Local/lxss/rootfs/usr/bin/qmlscene
find: ‘./var/run/user/1000/gvfs’: 权限不够
./run/media/xuan/60169D27169CFEEA/Users/liangzi/AppData/Local/lxss/rootfs/usr/bin/qmlscene
find: ‘./run/user/1000/gvfs’: 权限不够
./opt/Qt/5.7/gcc_64/bin/qmlscene

尼马~~~~~~~~~~

然后重新更改目录为最后的这个 搞定啦

为毛系统原来的目录里面没有这个文件呢 这个发行版可是自带的QT啊 比较无语

==========================

解决 QtCreator无法输入中文

保存以下文件为shell脚本 添加可执行权限 搞定!

#!/bin/bash
set -v
echo "以下命令解决 Qt Creator 4.2.0 (4.2.0)无法输入中文"
cd /opt/Qt/Tools/QtCreator/lib/Qt/plugins/platforminputcontexts/
sudo cp /usr/lib64/qt5/plugins/platforminputcontexts/libfcitxplatforminputcontextplugin.so .

其他操作系统参考这里:

http://my.oschina.net/lieefu/blog/505363?p=3#comments
http://www.ithao123.cn/content-10902646.html

其实就是缺少fcitx输入法的共享链接库 比较无语的是里面竟然默认有ibus的共享链接库~~~~

动态链接的知识:Linux 动态库剖析---IBM Developerworks

上一篇: netdata

下一篇: conky显示实时缓存

423 人读过
立即登录, 发表评论.
没有帐号? 立即注册
0 条评论
文档导航